Slipping and adding tension?

Get the most out of your extender device! Communicate with users and experts that have had success with penile traction therapy.
Post Reply
jediknight
Posts: 4
Joined: Wed Sep 09, 2015 1:38 pm

Slipping and adding tension?

Post by jediknight » Wed Sep 09, 2015 2:27 pm

Hi,

I bought the X4 labs deluxe extender over 2 weeks ago and have seen the videos on the dvd on how to install the device. I bought the quad support system also because the website says it's for people with 1-3.9" length in flaccid state which it where I'm at. The first week I spent 2 consecutive days with 2 hours each day trying the noose, velcro, and plastic strap and neither hold my penis in. Keep in mind I used the lower part of the quad device. The dvd is very vague on how to adjust tension. The 3rd day I tried the upper half of the quad support and again, I'd slip out or the screws would come out of the O shaped base. I gave up and the next week I tried it again and the same thing happens. I read I'm not supposed to have the head of my pens strapped in too tightly but I don't have it very loosely in either.

I stretch my penis and put on the foam under the head. I pushed the device all the way down while strapping the head in and I let the top part uncompress. I turn the bottom screws clockwise and I either slip out of the device or I keep turning the screws and the rods won't even get down to the first tension level and actually comes loose from the O shaped base. I notice the bars above the screws (not the actual rods around the tip of my penis), get uneven when adding tension? Is that supposed to happen? I turn those bars back down to the level of the screws. I haven't added any extra rods since I just started the routine. The bars stay at the maximum tension of 3 lines. All the links I've seen in another thread are dead from over 6 yrs ago including the private youtube tutorials. Only the official ones from the company are there. What do I do to fix this?

izzy
Duke
Posts: 220
Joined: Fri May 22, 2015 10:45 am

Re: Slipping and adding tension?

Post by izzy » Wed Sep 09, 2015 11:26 pm

Stop turning the screws. The video is a tutorial showing you everything you can do with the device. Just because they turn the screws in the video doesn't mean that you have to turn the screws every time you use it.

I have only turned the screws one time during the 3+ months that I have been stretching. Give your body some time to adjust to stretching. Chances are, you will pull out a lot of hidden length just by keeping your penis pulled out for extended periods of time.

Keep everything screwed until you get more comfortable with using it. After a couple of weeks of no screws, strap yourself in and give it a good 15-20 minutes into the session before even thinking about touching the screws.

jediknight
Posts: 4
Joined: Wed Sep 09, 2015 1:38 pm

Re: Slipping and adding tension?

Post by jediknight » Mon Sep 21, 2015 12:52 pm

I still have problems and moved this over to the main thread "How to put it on?" .

Ogenki1
Duke
Posts: 139
Joined: Fri Oct 30, 2015 4:58 pm

Re: Slipping and adding tension?

Post by Ogenki1 » Tue Dec 15, 2015 12:20 pm

I agree with the previous poster stating you should leave the screws alone for a while. Also, be sure to stretch or jelq before you start. This can really help.

Dangler
Duke
Posts: 684
Joined: Fri Aug 21, 2009 2:34 pm

Re: Slipping and adding tension?

Post by Dangler » Wed Dec 16, 2015 9:19 am

If when turning the adjusting screws, they come out of the base....This means you need to build the extender longer, then put it on. Remember to turn the screws all the way back :-?
Try adding the smallest length rod, then try again.


Post Reply