is this normal???

Get the most out of your extender device! Communicate with users and experts that have had success with penile traction therapy.
Post Reply
1337Nu7z
Posts: 3
Joined: Sun Dec 11, 2011 10:49 pm

is this normal???

Post by 1337Nu7z » Sun Dec 11, 2011 11:10 pm

i got the premium gold package on dec 1st i started using it on the 3rd and it is now the 11th at 11:03 pm and my fully erect penis is 6.8 in. i started on the 3rd with a fully erect penis of 6 in... ive read some other peoples stories. should i be worried if its growing so fast. im 21 years old the system doesnt hurt me when i use it. any feedback?

romeox929
Posts: 6
Joined: Fri Dec 09, 2011 2:49 pm

Re: is this normal???

Post by romeox929 » Tue Dec 13, 2011 10:09 pm

normal for you..wish I had your "normal" :lol:

1337Nu7z
Posts: 3
Joined: Sun Dec 11, 2011 10:49 pm

Re: is this normal???

Post by 1337Nu7z » Wed Dec 14, 2011 11:44 pm

lol @ romeox. i wear it every day for 3 hours. thats all nothing else. o ya that and a lot of sex. can people plz quit spamming?

Debo19832003
Knight
Posts: 46
Joined: Mon Sep 26, 2011 10:51 pm

Re: is this normal???

Post by Debo19832003 » Fri Dec 16, 2011 6:58 am

I qwest mine 12 hours a day 5 days a week.i haven't gotten those types of gains.god bless you.lol are your measuring right after you take off the device or do you wait a hour then measure?

1337Nu7z
Posts: 3
Joined: Sun Dec 11, 2011 10:49 pm

Re: is this normal???

Post by 1337Nu7z » Fri Dec 16, 2011 9:37 am

i measure before i even put it on for the day.

x4cure
Knight
Posts: 10
Joined: Mon Jul 25, 2011 9:35 pm

Re: is this normal???

Post by x4cure » Wed Dec 21, 2011 7:28 pm

Yes it is normal.

Some people have Newbie gains.

I was one of them : )

However the growth from now on is probably going to be much slower.

Happy Growing.

Debo19832003
Knight
Posts: 46
Joined: Mon Sep 26, 2011 10:51 pm

Re: is this normal???

Post by Debo19832003 » Sun Dec 25, 2011 2:46 pm

That is crazy I've been wearing mine for more than a month for 12 hours I'm not even close to that. Damn.

aznsilo
Knight
Posts: 27
Joined: Wed Sep 19, 2012 8:14 pm

Re: is this normal???

Post by aznsilo » Thu Oct 04, 2012 6:13 pm

Right after I use the extender after 3-4 hours, I see a sudden increase in flaccid length, but it goes right back down. So far I've seen no gains after 3 months. Also, after your gains start to slow down I think it's better to take off a week or so and then start again.

Trigger
Knight
Posts: 17
Joined: Fri Aug 17, 2012 12:48 pm
Location: Canada

Re: is this normal???

Post by Trigger » Sat Oct 13, 2012 9:40 am

Pretty much the same here. I can not imagine wearing it for 12 hours? Do you take breaks ? I have mine on for 30 mins / off for 5 . They never tell you about the circulation issue. I have read about getting nerve damage if you cut that off for too long.

aznsilo
Knight
Posts: 27
Joined: Wed Sep 19, 2012 8:14 pm

Re: is this normal???

Post by aznsilo » Thu Nov 08, 2012 6:59 am

If I feel no pull does it mean it's not working? Normally when I increase rod length and increase the tension I feel a pull, but this time it's not working, what should I do?

Trigger
Knight
Posts: 17
Joined: Fri Aug 17, 2012 12:48 pm
Location: Canada

Re: is this normal???

Post by Trigger » Mon Nov 19, 2012 2:30 pm

You need to adjust the screws to increase the pull. If you have the standard springs (1500g), each mark is 500gs . There are 3 marks on the bars that you can screw in/out.
Last edited by Trigger on Mon Nov 19, 2012 2:42 pm, edited 1 time in total.

Trigger
Knight
Posts: 17
Joined: Fri Aug 17, 2012 12:48 pm
Location: Canada

Re: is this normal???

Post by Trigger » Mon Nov 19, 2012 2:32 pm

FYI, I find to have it tight enough to pull 800gs or more I lose circulation. In this case I do it with 20-25 min intervals with a 5 min break.

Post Reply